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Customer Support
You can obtain technical support by using the Support page on the BMC Software Web site or by contacting 
Customer Support by telephone or e-mail. To expedite your inquiry, please see “Before Contacting BMC 
Software.”

Support Web Site

You can obtain technical support from BMC Software 24 hours a day, 7 days a week at 
http://www.bmc.com/support.html. From this Web site, you can

• read overviews about support services and programs that BMC Software offers
• find the most current information about BMC Software products
• search a database for problems similar to yours and possible solutions
• order or download product documentation
• report a problem or ask a question
• subscribe to receive e-mail notices when new product versions are released
• find worldwide BMC Software support center locations and contact information, including e-mail addresses, 

fax numbers, and telephone numbers

Support by Telephone or E-mail

In the United States and Canada, if you need technical support and do not have access to the Web, call 
800 537 1813. Outside the United States and Canada, please contact your local support center for assistance. To 
find telephone and e-mail contact information for the BMC Software support center that services your location, 
refer to the Contact Customer Support section of the Support page on the BMC Software Web site at 
www.bmc.com/support.html.

Before Contacting BMC Software

Before you contact BMC Software, have the following information available so that Customer Support can begin 
working on your problem immediately:

• product information

— product name
— product version (release number)
— license number and password (trial or permanent)

• operating system and environment information

— machine type
— operating system type, version, and service pack or other maintenance level such as PUT or PTF
— system hardware configuration
— serial numbers
— related software (database, application, and communication) including type, version, and service pack or 

maintenance level

http://www.bmc.com/support.html
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• sequence of events leading to the problem

• commands and options that you used

• messages received (and the time and date that you received them)

— product error messages
— messages from the operating system, such as file system full
— messages from related software 
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About . . .

About This Book

This book describe how to implement and administer 
CONTROL-M/Agent for Microsoft Windows. The following table 
describes the chapters of this book:

Chapter 1 General Information
Introduces key features and concepts of CONTROL-M/Agent.

Chapter 2 Implementing CONTROL-M/Agent
Describes how to 
• maintain CONTROL-M/Agent Services
• Set user rights
• Register users and passwords
• Use the CONTROL-M/Agent GUI
• Send messages to an e-mail address
• Modify and repair the CONTROL-M/Agent program

Chapter 3 Writing Scripts
Describes how to write CONTROL-M/Agent scripts.

Chapter 4 Utilities
Describes CONTROL-M/Agent command-line utilities.

Chapter 5 Defining Windows 2000 Jobs
Describes how to set job object limits for a CONTROL-M job.

Appendix A Configuration Parameters
Describes how to set and modify configuration parameters.

Index
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Related Publications

• CONTROL-M Installation Guide describes the installation of 
CONTROL-M components.

• CONTROL-M/Server Administrator Guides each describe setup, 
maintenance, security, and utilities for CONTROL-M/Server on a 
specific type of computer.

• CONTROL-M Job Parameter and Variable Reference Guide 
describes syntax and usage for all parameters and variables that are 
included in CONTROL-M job processing definitions.

• CONTROL-M/Desktop User Guide describes how to define and 
manage CONTROL-M job processing definitions, Scheduling tables, 
and Calendars.

• CONTROL-M/Enterprise Manager User Guide describes 
CONTROL-M/EM concepts, features, facilities, and operating 
instructions.

• CONTROL-M/eTrigger Administrator Guide describes how to 
trigger job submission and tracking activities using a web-based 
(HTML) interface.
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Notational Conventions

The following abbreviations are used in this guide:

The following conventions are used in this guide:

Abbreviation Description

CM CONTROL-M/Control Module
A product library for a specific application or operating 
system used by CONTROL-M/Agent to support that 
application or operating system.

CONTROL-M/EM CONTROL-M/Enterprise Manager

Convention Description

<key> When describing keystrokes, angle brackets are used to 
enclose the name of a key (for example, <F1>). When 
two keys are joined with “+” as in <Shift>+<F1>, hold 
down <Shift> while pressing <F1>.

Menu => Option This represents an option selection sequence.
For example: 
Users and Groups => Groups => Add 
means that you first select Users and Groups from the 
menu bar; then select the Groups option from the 
submenu. Finally, select the Add option from the 
Groups submenu.

{Option A|Option B} The vertical bar is used to separate choices. For 
example, when used as part of a parameter, {AND|OR} 
means that you specify either AND or OR.

[Parameter] Square brackets are used to enclose parameters that 
are optional.

<variable> In commands and parameters, angle brackets are used 
to enclose variable information. For example, the 
command:
cd <controlm_path>
means that you specify cd followed by the path of 
CONTROL-M.

italic An italic font is used for the name of publications.
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1

Understanding CONTROL-M/Agent 1

This guide describes concepts and tools required by the administrator to 
set up and manage CONTROL-M/Agent on Microsoft Windows 
computers.

CONTROL-M/Agent is a component of the CONTROL-M scheduling 
solution. The integration of these products is illustrated in Figure 1-1 on 
page 1-2.

CONTROL-M/Server handles production control and scheduling, and 
submits and tracks jobs across your network.

CONTROL-M/Agent submits jobs for execution on the Agent computer, 
monitors the jobs, and performs post-processing analysis of sysout files. 
The completion status of jobs and the results of post-processing analysis 
are transmitted back to CONTROL-M/Server.

Other CONTROL-M products are described in the documents listed in 
“Related Publications” on page -xii.
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Figure 1-1   CONTROL-M Scheduling Solution

Table 1-1 CONTROL-M Products

Product Description

CONTROL-M/EM GUI-based control center from which you can 
manage all scheduling and workflow activities.

CONTROL-M/Server Engine (on a Unix or Microsoft Windows computer) 
used to drive scheduling in a data center. Each 
CONTROL-M/Server can manage multiple 
CONTROL-M/Agents on various computers.

CONTROL-M/Agent Software responsible for job submission and 
execution. An Agent must exist on each computer 
that is used to execute CONTROL-M jobs.

CONTROL-M/eTrigger Web-based product that creates and runs jobs 
under CONTROL-M using input from a web page.

CONTROL-M/Control 
Modules

CONTROL-M Control Modules enable 
CONTROL-M/Agents to interface with other 
applications (for example SAP and Oracle 
Applications).
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CONTROL-M/Agent Functions

Job handling requests managed by CONTROL-M/Agent can consist of 
any of the following: 

• Instructions to submit a job on the Agent computer.

• Requests for information about jobs on the Agent computer that have 
been submitted, are currently executing, or have recently completed.

• Requests to view or edit job script statements.

• Requests to view job output (sysout) or job documentation.

• Requests to stop jobs that are currently executing.

In addition, CONTROL-M/Agent can handle job output (sysout) and 
issue Shout messages according to job processing parameters supplied 
with a job submission request.
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CONTROL-M/Agent Concepts

Additional information about CONTROL-M/Agent is contained in the 
following table.

Table 1-2 CONTROL-M/Agent Information

Item Description

Installation Information about installing and upgrading 
CONTROL-M/Agent for Microsoft Windows is described in 
the CONTROL-M Installation Guide.

Configuration 
Parameters

CONTROL-M/Agent configuration parameters are assigned 
values during the installation procedure.
• Table A-1 on page A-1 lists these parameters and their 

default values.
• BMC recommends using the ctmagcfg utility (described on 

page 4-8) to modify these parameters. However, some of 
these parameters can also be modified by using the 
CONTROL-M/Agent GUI described on page 2-9.

Command-Line 
Utilities

Many CONTROL-M tasks can be implemented from a DOS 
command-line using utilities. For more information, see 
Chapter 4, “Utilities”.

Control 
Modules

A Control Module (CM) is a DLL component that enables 
CONTROL-M/Agent to interface with other applications in 
your data center. For example, the CM for SAP interfaces 
between CONTROL-M/Agent and SAP.
• The CONTROL-M/Agent installation procedure installs a 

Control Module for Microsoft Windows operating systems 
and assigns values to its configuration parameters.
Note: Control Modules are installed only on the default 
CONTROL-M/Agent.

• Table A-2 on page A-4 lists these parameters and their 
default values.

• BMC recommends using the ctmwincfg utility (described 
on page 4-19) to modify these parameters. However, 
some of these parameters can also be modified by using 
the CONTROL-M/Agent GUI described on page 2-9.
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Server and Agent Communication

More than one CONTROL-M/Agent can reside on a computer. This 
enables more than one CONTROL-M/Server to communicate with 
different Agents on the same computer. For example, a 
CONTROL-M/Server can submit a job to an Agent in a test environment 
while another CONTROL-M/Server can send an accounts payable job to 
the same computer, using a different Agent.

One CONTROL-M/Agent can communicate with various 
CONTROL-M/Servers, for example, where jobs are submitted to an 
Agent from one CONTROL-M/Server and thereafter other jobs are 
submitted to the same Agent from a different CONTROL-M/Server. 

Communicating With a Specific CONTROL-M/Agent

Each CONTROL-M/Agent that resides on the same computer has a 
different Server-to-Agent listening port. CONTROL-M/Server 
communicates with a specific CONTROL-M/Agent by referring to its 
listening port.

The -agent <agent name> parameter is used in CONTROL-M/Agent 
utilities to specify which CONTROL-M/Agent will handle that utility. 
The variable <agent name> represents the name of the 
CONTROL-M/Agent specified during the installation procedure. 

For most utilities if the -agent parameter is not specified, the default 
CONTROL-M/Agent for that computer is used. However, if a 
configuration utility is run without specifying the -agent parameter, the 
user is prompted to select the CONTROL-M/Agent. For more 
information about invoking CONTROL-M/Agent utilities, see “Invoking 
A Utility On A Computer With Multiple Agents” on page 4-4.

The default CONTROL-M/Agent is determined by upgrading an earlier 
version of CONTROL-M/Agent, or during the installation procedure, as 
described in the Table 1-3.
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After Default CONTROL-M/Agent is installed on a computer, the 
installation procedure prompts for a name (free text, not case sensitive) 
for each subsequent CONTROL-M/Agent that is installed on the same 
computer. 

Note
Control Modules can be installed only on Default CONTROL-M/Agent.

Table 1-3 Determining the Default CONTROL-M/Agent

Method Description

Upgrade When upgrading CONTROL-M/Agent from an earlier 
version, that Agent is automatically set as the default.

Installation Procedure During installation of the first CONTROL-M/Agent, the 
user can select the Agent as default.
• If selected, this CONTROL-M/Agent is set as 

Default. If the user specifies a name for the Agent, 
the Agent must be referred to by that name when 
specifying the -agent parameter. For more 
information about the -agent parameter, see 
Chapter 4, “Utilities”.
Note: The name Default (not case sensitive) is a 
reserved name.

• If not selected, a subsequent CONTROL-M/Agent 
can be selected as default.
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2

Implementing CONTROL-M/Agent 2

The procedures and facilities described in this chapter enable you to keep 
CONTROL-M/Agent running efficiently.

The following topics are discussed in this section:

• “Maintaining CONTROL-M/Agent Services” below
• “Configuring Agent and Tracker Service Properties” on page 2-4
• “Starting/Stopping Agent and Tracker Services” on page 2-5
• “Determining the Owner of Jobs Run on the Agent” on page 2-6
• “How to Assign User Rights to Agent Users” on page 2-8
• “Using the CONTROL-M/Agent GUI” on page 2-9
• “Sending a Shout Message to an E-mail Address” on page 2-25
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Maintaining CONTROL-M/Agent Services

The following CONTROL-M/Agent services are installed during the 
CONTROL-M/Agent installation procedure:

• CONTROL-M Agent Service
• CONTROL-M Tracker Service
• CONTROL-M FileWatcher Service

CONTROL-M Agent and Tracker Services

The CONTROL-M Agent and Tracker services can run as Microsoft 
Windows background processes that are transparent to the user. These 
services remain active as long as Microsoft Windows is running. For 
more information, see “Starting/Stopping Agent and Tracker Services” 
on page 2-5.

Specifying the Agent Service and Tracker Service User Account

The Log On panel prompts you to select Local System account or This 
Account. For more information, see “Configuring Agent and Tracker 
Service Properties” on page 2-4.

• If Local System account is selected, the service will run in the 
administrative group and in the native system account environment. 
By installation default, the following options are selected:
— (Log on as:) “Local System Account”
— “Allow service to interact with desktop”

These options enable the Agent service and Tracker service to open 
windows in the Microsoft Windows desktop. However, the Local 
System Account cannot access files across a network and cannot 
send a Shout message to an e-mail destination.
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• If the owner of any jobs run by CONTROL-M/Agent has a 
“Roaming Profile”, select This Account mode. If This Account is 
selected, specify an Administrators group user and password. The 
service will run in the specified user environment. The format for the 
value in the This Account text box is <Domain>\<User>. For more 
information, see “Support for Roaming Profile” on page 2-4.

In either case, the service’s logon on account must have these user rights 
(see “How to Assign User Rights to Agent Users” on page 2-8):

• act as part of the operating system
• debug programs
• increase quotas
• logon as a batch job (recommended)
• logon as service
• replace process level token

Support for Roaming Profile

CONTROL-M/Agent support for “Roaming Profile” requires the 
following:

• The profile must reside on the network. If the network path includes 
the environment variable, CONTROL-M/Agent expands the path and 
loads the User Profile from the expanded path.

• After loading the user profile, CONTROL-M/Agent sets all 
environment variables from the roaming profile:

— Logs into a different computer with the roaming user
— Changes/adds the private environment variable
— Logs out
— Runs the CONTROL-M job on the original computer

• New environment variables or updated variables performed by the 
roaming user on any computer will be detected by the CONTROL-M 
job.
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Configuring Agent and Tracker Service Properties

Summary: You can modify Agent service and Tracker service properties in the 
Log On panel of the CONTROL-M Agent (or Tracker) Properties 
window. BMC recommends that the same properties be specified for both 
the Agent service and the Tracker service.

Before You Begin

Default values for Agent and Tracker service properties were set during 
the CONTROL-M/Agent installation. You can modify these properties.

Note
If the owner of any CONTROL-M jobs has a “roaming profile”, the 
Logon mode must be set to This Account. Otherwise, the Local System 
Account logon mode is recommended.

How to Display and Modify CONTROL-M Agent (or Tracker) Properties

Step 1 Choose Start => Settings => Control Panel => Administrative Tools 
=> Services.

Step 2 The Services window is displayed. Right-click CONTROL-M Agent or 
CONTROL-M Tracker and choose Properties.

Step 3 The CONTROL-M Agent (or Tracker) Properties (Local Computer) 
window is displayed. Click the Log On tab.

Step 4 The Log On panel is displayed. Select the desired properties and click 
OK.

CONTROL-M FileWatcher Service

BMC Software recommends that you do not make any changes to this 
service.
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Starting/Stopping Agent and Tracker Services

Summary: The Agent and Tracker services operate as background processes that are 
not visible to the user. When the computer is turned on or rebooted, these 
services start automatically if the Startup Type configuration parameter is 
set to Automatic. (See “Startup Type” on page A-6.) These services 
remain active as long as Microsoft Windows is running.

If you stop these services, you can restart them manually (as described 
below), or you can reboot the system (if Startup Type is Automatic). If 
the Startup Type is set to Manual, you must start these services manually 
(as described below).

You can modify the Startup Type value. BMC recommends that the 
Agent service and the Tracker service be treated the same way. The 
recommended Startup Type is Automatic.

Starting CONTROL-M Agent and Tracker Services

Step 1 Select Start => Settings => Control Panel => Administrative Tools.

Step 2 In the Administrative Tools window, click Services.

Step 3 Select the CONTROL-M Agent service and click Start.

Step 4 Select the CONTROL-M Tracker service and click Start.

Stopping CONTROL-M Agent and Tracker Services

Step 1 Select Start => Settings => Control Panel => Administrative Tools.

Step 2 In the Administrative Tools window, click Services.

Step 3 Select the CONTROL-M Agent service and click Stop.

Step 4 Select the CONTROL-M Tracker service and click Stop.
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Determining the Owner of Jobs Run on the Agent

CONTROL-M/Agent runs a job in the environment of the owner of the 
job with the permissions granted to that owner.

The owner of a CONTROL-M/Agent job is determined by the value of 
the Logon As User configuration parameter. This parameter can be set 
during installation (see Chapter 12 in Book 2 of the CONTROL-M 
Installation Guide) or after installation (as described in the ctmwincfg 
utility on page 4-19).

• If Logon As User is set to Y, the owner of the job is the owner 
specified in the CONTROL-M job definition.

• If Logon As User is set to N, the owner of the job is the user account 
for the CONTROL-M/Agent service: the Local System account or 
the This Account user. For more information, see “Specifying the 
Agent Service and Tracker Service User Account” on page 2-2.

The following requirements must be satisfied:

• If a user with a “Roaming Profile” will be the owner of a job, specify 
This Account (and not Local System Account) in the 
CONTROL-M/Agent Service Definition window.

• To enable a specific user to run (be the owner) of CONTROL-M 
jobs, the password of the user must be entered into CONTROL-M 
using the ctmpwd utility.

• The owner must have access rights to the network and the Log on as 
a batch job user right.
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For information about how to assign user rights, see page 2-8.

Note
To eliminate the need to assign user rights to every job owner on every 
Microsoft Windows computer running CONTROL-M/Agent, BMC 
recommends that you define a domain-level group for all job owners. 
You can name this group “CONTROL-M Job Owners”. Assign network 
access rights and the Logon as a batch job user right to this group.
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How to Assign User Rights to Agent Users

Summary: You can use this procedure to assign the user rights listed on page 2-3 to 
each user who needs them.

How to Assign User Rights

Step 1 Log on to the CONTROL-M/Agent computer as a local administrator.

Step 2 Choose Start => Settings =>Control Panel=> Administrative Tools => 
Local Security Policy.

Step 3 In the displayed tree structure, select Local Policies. 

Step 4 In the displayed panel, double-click User Rights Assignments to display 
the list of user rights.

Step 5 Double-click the user right you want to assign. The Local Security 
Policy Settings window for that user right is displayed.

5.A If the user who should have the selected user right is not listed in 
this window, click Add.

5.B In the bottom panel, enter the <domain>\<user_name> of the 
user and click OK.

5.C When the specified user is displayed in the lower panel, click 
OK again.

Step 6 Restart the Agent service to make the user rights effective.
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Using the CONTROL-M/Agent GUI

CONTROL-M/Agent has a GUI that can be used for adding and 
modifying configuration parameters. The configuration utilities can also 
be used. 

Procedures to perform the following tasks are described in this section:

• Modifying configuration parameters (see page 2-10)
• Modifying system configuration parameters (see page 2-13)
• Authorizing CONTROL-M Servers (see page 2-15.)
• Specifying a diagnostics level (see page 2-17
• Viewing and deleting log files (see page 2-18)
• Viewing and deleting diagnostics files (see page 2-20)
• Adding Job Object Statistics to Sysout (see page 2-22)
• Verifying Communications with the Server (see page 2-23)
• Generating a Communications Diagnostic Report (see page 2-24)
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Modifying Configuration Parameters

Summary: Configuration parameters for CONTROL-M/Agent and its Control 
Module component are set during installation. Most of these parameters 
can be modified. Use ctmagcfg, ctmwincfg, or the CONTROL-M/Agent 
GUI to view or modify these configuration parameters.

Before You Begin

Start the CONTROL-M/Agent GUI by selecting Start => Programs => 
CONTROL-M Agent 6.1.03 => CONTROL-M Agent <agent name>.

Note
The CONTROL-M/Agent GUI does not start the CONTROL-M Agent 
service. To start the CONTROL-M Agent service, see “Starting/Stopping 
Agent and Tracker Services” on page 2-5.

How to Modify Configuration Parameters

Step 1 Select Customize => Configuration Parameters. 

Step 2 The Agent Configuration window is displayed.



BMC Software, Inc., Confidential and Proprietary Information

Implementing CONTROL-M/Agent 2-11

Figure 2-1   Agent Configuration window

Step 3 Modify the parameters as required. Click OK.

Note
The Agent-to-Server port number and the Server-to-Agent port 
number are defined both on the Server computer and on each Agent 
computer. These parameters must have matching values in both locations. 

On most Server computers, the Server-to-Agent port number for each 
Agent is assigned a default value. However, a different value can be 
assigned to this parameter for each Agent computer.
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Where to Go from Here

The following table describes tasks that are related to this one.

Next Task Procedure

Perform other tasks in 
the list on page 2-9.

Follow the steps for the appropriate task as 
described on the page indicated in the list.

Exit the GUI. Select File => Exit from the menu bar.
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Displaying and Modifying System Configuration Parameters

Summary: The following system configuration parameters can be modified using 
the GUI: Logon As User, Logon Domain, and Domain Controller. 
These parameters are described in Table A-2, “Control Module 
Configuration Parameters,” on page A-4

Before You Begin

Start the CONTROL-M/Agent GUI by selecting Start => Programs => 
CONTROL-M Agent.

How to Display and Modify System Configuration Parameters

Step 1 Select Customize => Agent Configuration Parameters. 

Step 2 The System Configuration dialog box is displayed.

The parameters in this dialog box are described in Table A-2, “Control 
Module Configuration Parameters,” on page A-4.

Step 3 Change the parameters as required. Click OK. 
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Where to Go from Here

The following table describes tasks that are related to this one.

Next Task Procedure

Perform other tasks in 
the list on page 2-9.

Follow the steps for the appropriate task as 
described on the page indicated in the list.

Exit the GUI. Select File => Exit from the menu bar.
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Authorizing CONTROL-M/Servers

Summary: The Authorized CONTROL-M/Servers list includes all servers (including 
the primary server) that are authorized to send requests to 
CONTROL-M/Agent. The name of each server is separated by a 
| symbol (vertical bar) without blanks.

For more information about Authorized CONTROL-M/Servers, see the 
CONTROL-M/Agent chapter of the CONTROL-M Installation Guide.

Before You Begin

Start the CONTROL-M/Agent GUI by selecting Start => Programs => 
CONTROL-M Agent.

How to Display the Authorized Servers List

Step 1 Select Customize=>Authorized CONTROL-M/Servers.

Step 2 The Authorized CONTROL-M/Servers dialog box is displayed.

Step 3 Modify the Server computer host names as required. Click OK.

Step 4 Verify communication between the Agent computer and the primary or 
authorized Server computers. The instructions for performing this task 
are described in “Verifying Communication with the Server” on page 
2-23.
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Where to Go from Here

The following table describes tasks that are related to this one.

Next Task Procedure

Perform other tasks in 
the list on page 2-9.

Follow the steps for the appropriate task as 
described on the page indicated in the list.

Exit the GUI. Select File => Exit from the menu bar.
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Specifying a Diagnostic Level

Summary: Diagnostic messages are recorded in a diagnostics file. The detail and 
content of the messages is dependent on the current diagnostic level.

Before You Begin

Shut down CONTROL-M/Agent.

How to Specify a Diagnostic Level

Step 1 Select Diagnostics => Set Diagnostic Level.

Step 2 The Agent Diagnostic Level dialog box is displayed.

Select the desired diagnostic level in the dialog box. Click OK.

Step 3 Restart CONTROL-M/Agent.

Where to Go from Here

Next Task Procedure

Perform other tasks in 
the list on page 2-9.

Follow the steps for the appropriate task as 
described on the page indicated in the list.

Exit the GUI. Select File => Exit from the menu bar.
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Viewing and Deleting Log Files

Summary: You can view log files containing messages that are transmitted between 
the Agent computer and CONTROL-M/Server, and log files containing 
diagnostic messages recorded on the Agent computer.

When the log files are no longer required, you can delete them.

Before You Begin

Start the CONTROL-M/Agent GUI by selecting Start => Programs => 
CONTROL-M Agent.

How to View Log Files

Step 1 Select File => Show Log Files from the menu bar. 

Step 2 An Open File dialog box is displayed.

Step 3 Double-click the required file. The log file is displayed in Notepad.
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How to Delete Log Files

Step 1 Select File => Delete Log Files from the menu bar. 

Step 2 A confirmation window is displayed. 

Step 3 Click OK. All log files are deleted.

Where to Go from Here

The following table describes tasks that are related to this one.

Next Task Procedure

Perform other tasks in 
the list on page 2-9.

Follow the steps for the appropriate task as 
described on the page indicated in the list.

Exit the GUI. Select File => Exit from the menu bar.
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Viewing and Deleting Diagnostics Files

Summary: You can view diagnostics files containing messages that are generated 
according to the diagnostics level specified. When the diagnostics files 
are no longer required, they can be deleted.

Note
For more information about diagnostic levels, see “Specifying a 
Diagnostic Level” on page 2-17. 

How to View Diagnostics Files

Step 1 Select File => Show Diagnostic Files from the menu bar. 

Step 2 An Open File dialog box is displayed.

Step 3 Double-click the required file. The selected file is displayed in Notepad.



BMC Software, Inc., Confidential and Proprietary Information

Implementing CONTROL-M/Agent 2-21

How to Delete Diagnostics Files

Step 1 Select File => Delete Diagnostic Files from the menu bar. A confirmation 
window is displayed.

Step 2 All CONTROL-M/Agent diagnostics files are deleted after confirmation.

PROCLOG Retention Period

CONTROL-M/Server ctmsys utility passes the “Maximum Days to 
Retain Sysout Files” parameter to CONTROL-M/Agent when the New 
Day Procedure is invoked. This parameter determines the retention 
period in the Agent for job output (sysout) files.

To change the default retention period for logs in the proclog directory, 
see ctmsys utility in the CONTROL-M/Server Administrator Guide.

Where to Go from Here

The following table describes tasks that are related to this one.

Next Task Procedure

Perform other tasks in 
the list on page 2-9.

Follow the steps for the appropriate task as 
described on the page indicated in the list.

Exit the GUI. Select File => Exit from the menu bar.
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Adding Job Object Statistics to Sysout

Use the following steps to add job object statistics to sysout:

Step 1 Select Diagnostics => Options from the menu bar. 

Step 2 The Job Object Statistics check box is displayed.

Figure 2-2   Job Object Statistics check box

Step 3 Select or clear the Job Object Statistics check box as required. Click OK.

• If you select the check box, job object statistics are written to the 
sysout file. 

• If you clear the check box, job object statistics are not written.

Where to Go from Here

The following table describes tasks that are related to this one.

Next Task Procedure

Perform other tasks in 
the list on page 2-9.

Follow the steps for the appropriate task as 
described on the page indicated in the list.

Exit the GUI. Select File => Exit from the menu bar.
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Verifying Communication with the Server

Summary: BMC recommends that you verify the ability of the Microsoft Windows 
Agent computer to communicate with the primary Server computer and 
with all other authorized Server host computers. Use the following steps 
to verify communication with a Server computer:

How to Verify Agent - Server Communications

Step 1 Open a DOS window on the CONTROL-M/Agent computer and specify 
the command: ping <host_name>
The variable <host_name> is the name of the primary Server 
computer or one of the authorized Server computers.

• If the ping is successful, you receive a response that begins:
Pinging <host_name> [<IP_address>] with ...
Reply from <IP_address> ...

• If the ping is unsuccessful and you receive the response
Request timed out
then either the Server is down or there are connection problems.

• If the ping is unsuccessful and you receive the response
Unknown host <host_name>
verify that the host name is specified correctly.

Step 2 If the ping is still unsuccessful and the Microsoft Windows computer 
does not use DNS (Domain Name System) for host name resolution, 
check that the host name is defined in the hosts file for the computer. The 
hosts file is usually located under the following directory: 
c:\winnt\system32\drivers\etc\

If the host name of the Server computer is not listed in the hosts file, you 
can add an entry for the Server computer in the format: 
<IP_address> <host_name>

Example

128.128.100.12 diana
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Generating the Communication Diagnostic Report

Summary: CONTROL-M/Agent includes a diagnostic program that checks 
parameters and environmental conditions relevant to communication 
between the Agent and Server computers. This program is typically used 
at the request of Technical Support to determine the cause of a 
communication problem.

How to Generate the Communication Diagnostic Report

Step 1 Navigate to the <CONTROL-M Agent>\util directory.

Step 2 Specify the command: ag_diag_comm. After several seconds, the 
CONTROL-M/Agent Communication Diagnostic Report is displayed.

Control-M/Agent Communication Diagnostic Report
-----------------------------------------------

User Name                      : abercovi: Administrator
CONTROL-M/Agent Directory      : D:\Program Files\BMC Software\CONTROL-M 
Agent\
Agent Platform Architecture    : <platform> (Build:<nnnn>)
FD Number                      : FD4195
Agent Version                  : 6.1.01
Agent Platform Name            : TLVS2K038
Server Host Name               : piper
Authorized Servers Hosts Names : piper
Server-to-Agent Port Number    : 19000
Agent-to-Server Port Number    : 8805
Server-Agent Protocol Version  : 6
Server-Agent Comm. Protocol    : TCP
           CONTROL-M Agent           status: Not Running Locally
           CONTROL-M Tracker         status: Not Running Locally
           CONTROL-M FileWatcher     status: Not Running Locally
DNS Tarnslation of Server      : 172.16.130.197 (In 0 seconds)
Executing Ping to piper...
Pinging piper.isr.bmc.com [172.16.130.197] with 32 bytes of data:

Reply from 172.16.130.197: bytes=32 time<10ms TTL=255
Reply from 172.16.130.197: bytes=32 time<10ms TTL=255

Ping statistics for 172.16.130.197:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum =  0ms, Average =  0ms
System Ping to Server Platform : Success
**********************************************
Agent ping to Control-M/Server : piper
Output:
Server is alive.
Result: Success.
--- End of Report ---
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Sending a Shout Message to an E-mail Address

The CONTROL-M Shout facility sends messages to recipients based on 
specified logical destinations. For more information, see “Shout Facility” 
in Chapter 1 and “Shout Message Destinations” in Chapter 4 of the 
CONTROL-M/Server Administrator Guide.

CONTROL-M/Server can request CONTROL-M/Agent to send a 
message to an e-mail destination. If the destination is not a standard 
e-mail address, CONTROL-M/Agent will try to resolve the destination to 
an e-mail address using the Address Book of the default Windows 
Messaging Component (for example, Microsoft Outlook).

Requirements for Sending Shout Messages to E-mail Destinations

• The CONTROL-M/Agent service must run under the user specified 
in the This Account field of the Log On panel. See “Specifying the 
Agent Service and Tracker Service User Account” on page 2-2.

• The default Windows Messaging component must be installed and 
running on the Microsoft Windows Agent platform. This component 
is not installed by the CONTROL-M installation procedure.

• The user specified in the Mailbox field of the Windows Messaging 
Component and the user specified in the This Account field of the 
Log On panel must be identical.

To view or change the user in the This Account field, see “Configuring 
Agent and Tracker Service Properties” on page 2-4.

How to Configure the Mailbox Field in Microsoft Outlook

To view or change the user in the Mailbox field, close Microsoft 
Outlook, right-click the Microsoft Outlook icon, and choose Properties 
=> Services (tab) => Microsoft Exchange Server => Properties.
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Language Capabilities

Western European Languages

CONTROL-M/EM, CONTROL-M/Desktop, CONTROL-M/Server, 
CONTROL-M/Agent, and CONTROL-M/eTrigger, support Western 
European language characters (the Latin-1 character set). These products 
can accept characters in English, German, Spanish, and French from the 
Latin-1 character set (ISO 8859-1) in almost all text fields and 
parameters.

For additional information, see the following guides.

Task Topic and Guide

Indications of which parameters do 
not support Western European 
Language special characters

Individual parameter descriptions in 
the CONTROL-M/Enterprise Manager 
Parameter and Variable Reference 
Guide

Indications of which dialog boxes 
support Western European Language 
special characters

Individual descriptions of the various 
dialog boxes in the 
CONTROL-M/Enterprise Manager 
User Guide and the 
CONTROL-M/Desktop User Guide

Indications of which 
CONTROL-M/Server and 
CONTROL-M/Agent utilities do not 
support Western European Language 
special characters

The CONTROL-M/Server 
Administrator Guide and the 
CONTROL-M/Agent Administrator 
Guide

Language configuration instructions CONTROL-M Installation Guide

Upgrade and migration instructions CONTROL-M Upgrade Guide

CONTROL-M/eTrigger customization 
instructions

“Use Locale” topic in Chapter 4 of the 
CONTROL-M/eTrigger Administrator 
Guide
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Japanese

CONTROL-M can run on Japanese operating systems.

The CONTROL-M components, such as the EM GUI and 
CONTROL-M/Desktop, do not accept Japanese characters in any free 
text fields or parameters and display values only in English. For example, 
Japanese job sysouts do not display correctly. Therefore, in these cases, 
job sysout analysis is not possible.

No additional customization is necessary after installation or upgrade to 
run CONTROL-M components with Japanese operating systems.
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3

Writing Scripts 3

When operating in the Microsoft Windows environment, 
CONTROL-M/Agent supports the use of the following types of job 
scripts:

• DOS batch files (suffix .bat).
• REXX-language scripts (suffix .cmd).

CONTROL-M/Agent can use the On Statement/Code job processing 
parameters to perform post-processing analysis of the sysout of jobs 
submitted using these scripts.

The following topics are discussed in this chapter:

• Basic Guidelines
— On Statement/Code Parameter
— Utilization of Exit Codes by CONTROL-M/Server

• Script Utilities
— _exit
— _sleep

• Translating DOS Files and REXX Scripts to UNC
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Basic Guidelines

Scripts analyzed by CONTROL-M/Server as part of the post-processing 
of a job should comply with the following requirements:

• Begin the script with the command echo on. This ensures that job 
script statements will be written to the sysout file.

• End each prompt with a > or ] character. These characters and 
embedded spaces should not be used inside the prompt text string.

On Statement/Code Parameter

The following items describe how the On Statement/Code job 
processing parameter interprets script lines.

• Analysis of the Sysout for On Statement/Code

Text in a sysout file that follows a > prompt or ] prompt is treated by 
CONTROL-M/Server as part of the job script. All other text is 
treated as part of the operating system response.

When specifying an On Statement/Code statement (format 1) in a job 
processing definition, place text that follows either of these prompts 
in the Stmt parameter. Place other text in the Code parameter.

• Continuation Lines

CONTROL-M/Server does not process continuation lines for 
comparison with text in a Stmt subparameter. Therefore, do not 
specify script continuation line text in the Stmt subparameter.

• Length of Script Statement

CONTROL-M/Server compares the first 512 characters of a script 
statement with the text in subparameter Stmt. Text after the first 512 
characters of a script statement should not be in subparameter Stmt.
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The maximum length of the On Code parameter is 1024 characters.

For more information about the On Statement/Code parameter, see 
Chapter 7 of the CONTROL-M Job Parameter and Variable Reference 
Guide. Job processing parameters are described in Chapter 5 of the 
CONTROL-M/Enterprise Manager User Guide.

Utilization of Exit Codes by CONTROL-M/Server

Both DOS .bat scripts and REXX .cmd scripts can return an exit code to 
CONTROL-M/Server upon completion. The _exit utility described below 
is used by .bat scripts.

CONTROL-M/Server can distinguish between exit codes by using the 
following expression in the Code subparameter of the On Statement/Code 
job processing parameter:

COMPSTAT=<value>

Example

In this example, a REXX script exits with an exit code of 5, as follows:

exit  5

This condition can be detected by defining the following 
On Statement/Code parameter:

Stmt: *
Code: COMPSTAT=5
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Script Utilities

The _exit and _sleep script utilities can be accessed from within job 
scripts. These utilities are located in the <CONTRL-M/Agent>\EXE 
directory under the Product directory, for example:

c:\Program Files\BMC Software\CONTRL-M Agent\<agent name>\EXE

If this directory is not defined as part of the operating system search path, 
specify the full path when using one of these utilities.

_exit

This utility is similar to the Unix exit built-in shell function.

The utility is located in the <CONTRL-M/Agent>\EXE directory path 
that was created during the installation procedure.

Format

_exit [<exit code>]

The variable <exit code> is any whole number ≥ 0 Default: 0

The program exits with %errorlevel% = <exit code>

Examples

_exit 0 in a script causes the job to end with %errorlevel% 0.

ctmcreate -tasktype command -cmdline "_exit 0"

_exit 1 in a script causes the job to end with %errorlevel% 1.

ctmcreate -tasktype command -cmdline "_exit 1"
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_sleep

This utility is similar to the Unix sleep built-in shell function.

The utility is located in the <CONTRL-M/Agent>\EXE directory path 
that was created during the installation procedure.

Format

"... _sleep" <seconds>

The variable <seconds> is any whole integer number ≥ 0

Note
If _sleep is specified, it is mandatory to specify a whole integer 
number.

Example

Suspend execution of the script for 5 seconds.

ctmcreate -tasktype command -cmdline "_sleep 5"
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Translating DOS Files and REXX Scripts to UNC

The CTMBAT2UNC utility translates DOS batch files (.bat) and 
REXX-language (.cmd) scripts containing mapped path names into 
scripts that use Universal Naming Convention (UNC) equivalents to 
reference remote disk resources. These translated scripts enable 
CONTROL-M/Agent to execute multiple scripts simultaneously. The 
owners of the jobs do not have to be logged on to provide the drive 
mappings for the scripts.

The CTMBAT2UNC utility can be invoked using the following 
command:

ctmbat2unc.exe <batch_file_to_translate> <output_file_name>

Table 3-1 describes the CTMBAT2UNC utility parameters.

Example

Two job owners, A and B, are executing ScriptA.bat and ScriptB.bat, 
respectively. Owner A has drive M mapped to \\nt-A\share. Owner B has 
drive M mapped to \\nt-B\share.

Table 3-2 describes these scripts before and after executing the 
CTMBAT2UNC utility.

Table 3-1 CTMBAT2UNC Utility Parameters

Item Description

<batch_file_to_translate> Original .bat or .cmd script

<output_file_name> New script after translation
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As shown above, every line changed by the CTMBAT2UNC utility is 
marked by a REM comment inserted before the translated line.

Note
Under the current version of Microsoft Windows, command interpreters 
do not change a current directory to a UNC path (for example, 
cd \\nt-A\share\jobs will not be executed). BMC recommends 
that you review the translated script after invoking the ctmbat2unc utility.

Table 3-2 Scripts Before and After Running CTMBAT2UNC

Owner
Original 
Script Translated Script

A @echo off
dir M:\jobs

@echo off
REM Following line was changed 
by CTMBAT2UNC
dir \\nt-A\share\jobs

B @echo off
dir M:\jobs

@echo off
REM Following line was changed 
by CTMBAT2UNC
dir \\nt-B\share\jobs
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4

Utilities 4

Utilities are special programs that perform job definition, scheduling, and 
maintenance functions. These utilities can be invoked from a command 
line or by the Command parameter in a job processing definition.

Most of these utilities are executed in CONTROL-M/Server (see Figure 
4-1) and are documented in the CONTROL-M/Server Administrator 
Guide. The remaining utilities are documented in this chapter.

Figure 4-1   CONTROL-M/Server Utility Workflow 
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Note
If the primary CONTROL-M/Server does not respond to a 
CONTROL-M/Agent request to execute a utility (other than ag_ping), 
the request is automatically redirected to the first non-primary Server 
listed in the Authorized CONTROL-M/Server Hosts parameter. If the 
redirection is successful, that Agent continues to work with the 
replacement Server.

Timeout Intervals
The Timeout for Agent utilities parameter is described on page A-3. If 
the Agent invokes a utility that runs on the Server and there is no 
response within the timeout interval, the requested action will fail.

The ctmagcfg utility (see page 4-8) can modify this timeout interval. 
But, increasing this interval reduces CONTROL-M/Agent performance.

Specifying Utility Parameters

The command used to invoke a CONTROL-M utility is normally 
specified with all relevant parameters, for example:

ctmdefine -table cmmnds -jobname cmls13 \
-tasktype command  -group ecs  -application test \
-date 0101  -cmdline "dir \etc\passwd"

The total maximum length for all these parameters is 1000 characters. 
Using an input file enables you to:

• prepare and save files of utility parameters that can be reused.
• specify utility input longer than 1000 characters.
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The utilities in Table 4-1 allow you to place utility parameters in an input 
file. In this file, each parameter and its values (if any) are on a separate 
line with the same syntax they would have on a command line. 

Format for Command Lines With Spaces

If a command invoked from the Agent computer contains embedded 
spaces:

Add \” after the first quote at the beginning of the command, and add \” 
at the end of the command (but prior to any parameters). 

Example

“\”d:\program files\bmc software\control-m agent\util\_sleep\” 200”

Directing Output From Utilities

Some utilities generate reports that can be directed to a file. 

• If output parameters are specified, the utility output is directed to the 
specified file. 

• If output parameters are not specified, the output is routed to the 
default output device (for example, the logical name of a disk).

Table 4-1 Utilities That Support the -input_file Parameter

ctmcontb ctmorder

ctmcreate ctmshout

ctmdefine ctmvar

ctmkilljob ecaqrtab

ctmstvar 
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Invoking A Utility On A Computer With Multiple 
Agents

All CONTROL-M/Agent utilities now support the -agent <agent name> 
parameter. The variable <agent name> represents the name of the 
CONTROL-M/Agent specified during the installation procedure.

Where multiple CONTROL-M/Agents reside on a computer, the -agent 
parameter determines which CONTROL-M/Agent will handle the utility. 
If a configuration utility is run without specifying the -agent parameter, 
the user is prompted to select the CONTROL-M/Agent. For all other 
utilities, if the -agent parameter is not specified, the default 
CONTROL-M/Agent is used. For more information, see 
“Communicating With a Specific CONTROL-M/Agent” on page 1-5.

Example

Assume a computer has two Agents, Default and Saturn. To add a user 
to Default, use the following command:

ctmpwd -action add -user user2 -password 123456 -agent Default

-or-

ctmpwd -action add -user user2 -password 123456

To add a user to Saturn, use the following command:

ctmpwd -action add -user saturn_user2 -password 123456 -agent Saturn
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Utility Descriptions

Table 4-2 provides a short description of the utilities that can be invoked 
from CONTROL-M/Agent. Some of these utilities can use the -input_file 
parameter. For more information, see “Specifying Utility Parameters” on 
page 4-2.

Table 4-2 CONTROL-M/Agent Utilities (Part 1 of 2)

Utility Description

_exit Sets the completion status for a job run from a .bat file. Exit code 
0 is equivalent to Ended OK. Any other exit code is equivalent to 
Ended NOTOK. For more data, see page 3-4.

_sleep Determines the sleep time for all CONTROL-M/Server processes 
or for a specific process. For more information, see page 3-5.

ag_diag
_comm

• Verifies that the primary CONTROL-M/Server host is active by 
pinging the host via the CONTROL-M port.

• Displays CONTROL-M system information.
For more information, see “Generating the Communication 
Diagnostic Report” on page 2-24.

ag_ping Tries to communicate with CONTROL-M/Server and indicates 
whether the attempt succeeded or failed. For more information, 
see page 4-7.

ctmag Invokes the CONTROL-M/Agent GUI. For more information, see 
“Using the CONTROL-M/Agent GUI” on page 2-9.

ctmagcfg Interactively modifies CONTROL-M/Agent configuration 
parameters. For more information, see page 4-8.

ctmcontb Performs operations on the Prerequisite Conditions table. For 
more information, see the CONTROL-M/Server Administrator 
Guide.

ctmcreate Creates a job in the Active Jobs file. For more information, see 
the CONTROL-M/Server Administrator Guide.

ctmdefine Creates job processing definitions. For more information, see the 
CONTROL-M/Server Administrator Guide.

ctmfw Detects completion of file transfer activity. For more information, 
see page 4-10.

ctmkilljob Terminates an executing CONTROL-M job and all of its 
associated processes. For more information, see the 
CONTROL-M/Server Administrator Guide.
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ctmloadset Updates a Quantitative resource in the Resources table. You 
must provide all the required parameters on the command line. 
For more information, see the CONTROL-M/Server 
Administrator Guide.

ctmorder Orders or forces one or more jobs from a CONTROL-M 
scheduling table. For more information, see the 
CONTROL-M/Server Administrator Guide.

ctmpwd Maintains CONTROL-M user and password information. For 
more information, see page 4-17. (This utility replaces the 
ctmcpt utility in earlier versions.) 

ctmshout Issues a shout message to a specified destination. For more 
information, see the CONTROL-M/Server Administrator Guide.

ctmstvar Displays the current value of an AutoEdit variable or function.

ctmudly Orders jobs for a specific User Daily name. For more 
information, see the CONTROL-M/Server Administrator Guide.

ctmvar Maintains AutoEdit variables. For more information, see the 
CONTROL-M/Server Administrator Guide. 
Note: The value of parameter -filename is the full path and 
name of a file that is accessible to CONTROL-M/Server.

ctmwincfg Interactively maintains Control Module configuration parameters. 
For more information, see page 4-19.

ecactltb Displays a list of Control resources and the status of each one. 
For more information, see the CONTROL-M/Server 
Administrator Guide.

ecaqrtab Performs operations on the Quantitative resources table. You 
must provide all the required parameters on the command line. 
For more information, see the CONTROL-M/Server 
Administrator Guide.

Table 4-2 CONTROL-M/Agent Utilities (Part 2 of 2)

Utility Description
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ag_ping Utility

This utility verifies that CONTROL-M/Server is active on the Server 
computer connected to the Agent computer. From the operating system 
prompt, specify the command:

ag_ping

The utility attempts to communicate with CONTROL-M/Server and 
indicates whether the attempt succeeded or failed. If the attempt 
succeeds, you will receive the message:

Output:
Server is alive.
Result: Success.
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ctmagcfg Utility

This interactive utility enables you to view and modify the parameters 
listed in Table A-1 on page A-1. If the parameter you want to modify is 
not listed in Table A-1, see the “ctmwincfg Utility” on page 4-19.

Note
BMC recommends to not access the Registry directly but to use ctmagcfg 
or ctmwincfg instead.

This utility is located at <CONTROL-M Agent>\EXE\ctmagcfg. It 
must be invoked from the command prompt. A window similar to the 
following is displayed:

Agent Configuration Utility
Agent Name: Default

1)      Agent-to-Server Port Number . . . : [7005]
2)      Server-to-Agent Port Number . . . : [7006]
3)      TCP/IP Timeout. . . . . . . . . . : [60]
     For items 4 and 5 do not use IP address
4)      Primary CONTROL-M/Server Host . . : [TLVS2K174]
5)      Authorized CONTROL-M/Server Hosts : [TLVS2K174]
6)      Tracker Polling Interval. . . . . : [60]
7)      Diagnostic Level. . . . . . . . . : [0]
8)      AutoEdit Inline. . . . . . . (Y|N): [N]
9)      Comm Trace. . . . . .(0-OFF|1-ON) : [0]
10)     CTMS Address Mode . . . . . (IP|) : []
11)     Days To Retain Log Files. . . . . : [1]
12)     Daily Log File Enabled. . .  (Y|N): [Y]
13)     Timeout for Agent utilities . . . : [600]
14)     Protocol version. . . . . . . . . : [06]
15)     Listen to Net Card .(*ANY for all): [*ANY]
16)     SSL . . . . . . . . . . . . .(Y|N): [N]
17)     Common Event mechanism. . . .(Y|N): [Y]
18)     Tracker Port. . . . . . . . . . . : [5009]
19)     Tracker Report to Server. . .(Y|N): [Y]

s)      Save and Restart CONTROL-M/Agent Services
q)      Quit

Enter your choice:
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Changes to the Diagnostic Level parameter are saved and take effect 
immediately. If you change any other parameter, the configuration 
parameters are saved and CONTROL-M/Agent is restarted. For more 
information, see Appendix A, “Configuration Parameters.”

Note
The default Protocol version (see option 14 above) is 06. This value 
indicates that CONTROL-M/Agent will communicate with 
CONTROL-M/Server version 6.1.03. Do not change this value.
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ctmfw Utility (File Watcher)

The File Watcher utility, ctmfw, can be used to detect

• the successful completion of a file transfer activity
• the creation of a file
• the deletion of a file

The File Watcher utility is installed as a Microsoft Windows service but 
can be used as a utility from the <CONTROL-M/Agent>\exe directory. 
For a detailed description of this utility, see the CONTROL-M/Server 
Administrator Guide.

Usage as a Service

As a service, ctmfw takes its parameters (rules) during startup from the 
rull.dat file whose full path name is specified in 
<CONTROL-M/Agent>\data\ctmfw.cfg. 

To change one or more rules, change the contents of the rull.dat file or 
specify the full path name of a different file.

The full path name to the ctmfw.cfg configuration file must be specified 
under the following Microsoft Windows registry key that is generated 
automatically by the installation script:

HKEY_LOCAL_MACHINE\SOFTWARE\BMC Software\
CONTROL-M/FileWatcher\SYSPRM\File Watcher
Configuration File

The default value for this key is:
<CONTROL-M/Agent_install_directory>\DATA\ctmfw.cfg

BMC recommends that this default value not be changed.

The configuration file must contain the following line:
-input <rule_file_name>
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The variable <rule_file_name> is the full path name of a rule file 
containing the File Watcher rules. A sample rule file is illustrated on page 
4-15.

Usage as a Utility

When running as a utility, ctmfw is invoked from the command line. 
Rules can be provided on the command line or by a rule file. 

The syntax of the ctmfw utility is:

ctmfw FILE
      < mode (CREATE|DELETE)>  Default: CREATE

< minimum detected size <number>
[' '|Bytes|Kilo|Mega|Giga] >  Default: 0Bytes

      < interval between file searches (seconds) >   
Default: 60sec

      < interval between filesize comparison 
iterations (seconds) >  Default: 10 sec

      < number of iterations while size is static >  
Default: 3 iterations

      < time limit for the process (minutes).  
Default: 0 (no time limit)

        Effective while the file does not exist or,
        the file size is static and the minimum size
        was not reached >

< monitor file size when wildcard is used > 
Default: Y 

-or-

ctmfw -input <rule_file_name>

Note
As of version 6.1.03, the ctmfw utility can be used to monitor files larger 
than 4GB.

For more information about rule files, see “Rule File Structure” on page 
4-15.
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The parameters of the ctmfw utility are described in Table 4-3.

Note
The parameters in the ctmfw command are identified by their sequence. 
Although all parameters are optional, you cannot skip a parameter and 
assign a value to a subsequent parameter. The first value is assumed to be 
the desired mode, the second value is assumed to be the minimum 
detected size, and so forth. 
If only six values are specified, the default value for monitor file size 
when wildcard is used is used. If five parameters are specified, default 
values for time limit for the process and monitor file size when 
wildcard are used, and so forth. For example: 

ctmfw c:\tmp\temp1\CREATE 100 10

is resolved using default values for interval between filesize 
comparison iterations, number of iterations while size is static, time 
limit for the process, and monitor file size when wildcard is used as 
follows:

ctmfw c:\tmp\temp1\CREATE 100 10 10 3 0 Y

Table 4-3 ctmfw – Parameters (Part 1 of 3)

Param Description

FILE Path of the file to be detected. The file name can include mask 
character * to represent any number of characters (including no 
characters) or ? to represent any one character. In this case, 
enclose the full path name in quotation marks (for example, 
“c:\ctm\a*.txt”). If a file name in a Rules file (see page 4-15) 
contains a wildcard, the filename should not be enclosed in 
quotation marks. When a wildcard is used, the ctmfw utility does 
not monitor the size of the file unless the monitor file size 
when wildcard is used parameter is set to Y.
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mode CREATE Detects creation of a file. Default. File size is 
ignored if the filename parameter contains 
wildcards (unless the monitor file size when 
wildcard is used parameter is set to Y).
Note: If a mask is specified for the filename, 
• and the monitor file size when wildcard is 

used parameter is set to N, the ctmfw utility will 
end OK after detection of the first file that 
matches the specified mask.

• and the monitor file size when wildcard is 
used parameter is set to Y, the ctmfw utility will 
continue to monitor the size of the randomly 
selected file.

For more information about monitor file size 
when wildcard is used, see below.

DELETE Detects deletion of a file. When the ctmfw utility is 
run in this mode, it first checks for files that match 
the specified name. After a specified file is 
detected, the ctmfw utility checks at the specified 
interval for deletion of that file. Note: If a mask is 
specified as the filename, the ctmfw utility will end 
successfully only after all detected files that 
match the specified mask have been deleted.

minimum 
detected 
size

Minimum file size in bytes. This parameter is ignored if the FILE 
parameter contains wildcards (unless the monitor file size 
when wildcard is used parameter is set to Y) or if the mode 
parameter is set to DELETE. Default: 0 (any size detected).

interval 
between file 
searches

Interval between successive attempts to detect the 
existence/deletion of a file (in seconds). Default: 60

interval 
between 
filesize 
comparison         
iterations

Interval between attempts to monitor the size of a file after it is 
detected (in seconds). This parameter is ignored when using 
wildcards in FILE or when using DELETE mode. Default: 10

number of 
iterations 
while size is 
static

Number of attempts to monitor file size where the size remains 
static and greater than or equal to minimum detected size 
(indicating successful creation of the file). This parameter is 
ignored when using wildcards in FILE or when using DELETE 
mode. Default: 3

Table 4-3 ctmfw – Parameters (Part 2 of 3)

Param Description
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Example

To monitor the file size of files starting with the name giga, issue the 
following command:

ctmfw c:\temp\giga???.txt CREATE 300M 1 1 1 1 Y

Return Codes

The return codes listed in Table 4-4 are issued by the ctmfw utility after 
detecting if a file is created or deleted in the specified time frame.

time limit for 
the process

Maximum time (in minutes) to run the process without detecting 
the file at its minimum size (CREATE) or detecting its deletion 
(DELETE). If the file is not detected/deleted in this specified 
time frame, the process terminates with an error return code, as 
described in Table 4-4. Default: 0 (no time limit).

monitor file 
size when 
wildcard is 
used

Indicates whether file size should be monitored if the filename 
contains wildcards. This parameter is ignored if the filename 
does not contain a wildcard. Valid values:
N – do not monitor file size. 
Y – monitor the file size. Default.
If this parameter is set to Y and more than one file matches the 
specified mask, the ctmfw utility randomly selects one matching 
file, monitors its file size, and ignores all other matching files.

Table 4-4 ctmfw – Return Codes

Return Code Description

0 File successfully created (file arrived in the specified time 
frame and file size is above or equal to the minimum 
specified size) or deleted.

1 File was not created or deleted in the specified time frame.

7 Indicates that the ctmfw request timed-out.
Note: This return code will be issued only if the ctmfw utility 
is executed in command line mode.

Table 4-3 ctmfw – Parameters (Part 3 of 3)

Param Description
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Rule File Structure

A rule file can be used when running ctmfw as a service or as a utility. 
The following is an example of a rule file:

INTERVAL 5 
FROM_TIME 0001 
MIN_SIZE 50 
MIN_DETECT 5 
WAIT_TIME 2 
ON_FILEWATCH NONEXIST CREATE 10 3 1 
THEN 
DO_CMD "BAD FILE WAS CREATED IN 1 MINUTE" 
DO_COND ON_2 0101 + 
ELSE 
DO_CMD "GOOD FILE WAS NOT CREATED IN 1 MINUTE"
DO_CMD ctmshout -USER ECS -MESSAGE "Running the 
Filewatcher with default configuration!"
END_ON 

Any File Watcher command line option can be specified in a rule file. All 
parameters must be delimited by the new line character.

Example of invoking ctmfw with a rule file

ctmfw -input “c:\Program_Files\BMC_Software\
CONTROL-M_Agent\data\ctmfw_rull.dat”

File Watcher Silent Mode Registry Key

The FileWatcher service does not open an additional window during 
execution. If you want visual feedback while running the service, the 
following registry key setting must be changed to N.

HKEY_LOCAL_MACHINE\SOFTWARE\BMC_Software\ 
CONTROL-M\FileWatcher\SYSPRM\Silent_Mode
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Network Resources

The FileWatcher service running under the local system account cannot 
detect network resources (files located on remote systems). If you want 
the File Watcher to detect network resources, configure the FileWatcher 
Service to run under a regular user account.

FileWatcher Service Trace

When running as a service, ctmfw generates an execution log file. This 
file is saved in the CONTROL-M/Agent proclog directory under the 
following name:

U_CTMFW_<process_id>.log

By default, logs in the proclog directory are retained for 3 days. If the 
“maximum days to retain sysout” parameter is set to a number higher 
than 3, then logs will be retained in this proclog directory for the number 
of days specified in that parameter.

For information about the “maximum days to retain sysout” parameter, 
see “PROCLOG Retention Period” on page 2-21. For information about 
viewing logs in the proclog directory, see “How to View Diagnostics 
Files” on page 2-20.

Sample trace file

Figure 4-2   Sample Trace File Output
2002/03/10 13:04:24 182 FW:set INTERVAL=3
2002/03/10 13:04:24 182 FW:set MIN_SIZE=4
2002/03/10 13:04:24 182 FW:set FROM_TIME=0909
2002/03/10 13:04:24 182 FW:ctmfw:command line 'ON_FILEWATCH tst CREATE'(arg#=3). id=1.
2002/03/10 13:04:24 182 FW:ctmfw:command line 'ON_FILEWATCH prd CREATE 0 0 1 NOW 10'(arg#=8)id=2
2002/03/10 13:04:24 182 FW:ctmfw:command line 'ON_FILEWATCH abc DELETE 0 0 1 NOW 10'(arg#=8)id=3
2002/03/10 13:04:24 182 FW:File 'test' exists, its current size is 265. id=1.
2002/03/10 13:04:24 182 FW:File 'test' has reached  the minimum size of 4. size=265 bytes id=1.
2002/03/10 13:04:24 182 FW:File 'abc' does not exist. id=3.
2002/03/10 13:04:36 182 FW:File transfer was completed. The size of file 'test' is 265. id=1.
2002/03/10 13:04:36 182 FW:Executing:<ctmcontb add    'aaa' '0101'>
2002/03/10 13:05:09 182 FW:Executing:< dir >
2002/03/10 13:05:27 182 FW:File 'prd' was not CREATED within the time limit. id=2.
2002/03/10 13:05:27 182 FW:File prd will be scanned at 1315. id=2.
2002/03/10 13:05:27 182 FW:File 'abc' was not DELETED within the time limit. id=3.
2002/03/10 13:05:27 182 FW:File abc will be scanned at 1315. id=3.
2002/03/10 13:05:30 182 FW:File prd, is out of time window. next time:1315, id=2.
2002/03/10 13:05:30 182 FW:File abc, is out of time window. next time:1315, id=3.
2002/03/10 13:15:01 182 FW:File prd, entered the time window from '1315' for monitoring, id=2.
2002/03/10 13:15:01 182 FW:File abc, entered the time window from '1315' for monitoring, id=3.
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ctmpwd Utility

This utility adds, updates, and deletes CONTROL-M/Agent users and 
passwords. It also lists all users in the CONTROL-M/Agent password 
file. (This utility replaces the ctmcpt utility in earlier versions.)

Note
Full Control access to CONTROL-M/Agent directories is automatically 
given to new users. You must manually give Logon as a batch job rights 
to a new user. (See “How to Assign User Rights to Agent Users” on page 
2-8.)

Syntax

CTMPWD -ACTION ADD|UPDATE|DELETE|LIST [-USER <user name>] 
[[-OLD_PASSWORD <value>] -PASSWORD <value>] [-ADMIN_PASSWORD 
<value>]] -AGENT <agent name>

Examples

add a user and password

ctmpwd -action add -user user1 -password 12345

add the administrator user

ctmpwd -action add -user admin -password abcde

update a password

ctmpwd -action update -user user1 -old_password 12345 
-password 67890 
or
ctmpwd -action update -user user1 -admin_password 
abcde -password 67890 
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delete a user

ctmpwd -action delete -user user1 -password 12345
or
ctmpwd -action delete -user user1 -admin_password 
abcde

list all users

ctmpwd -action list

add a user to Agent Saturn

ctmpwd -action add -user user3 -password 654321 -agent Saturn

Restart CONTROL-M/Agent after using this utility. 

Example

-admin_password enables the CONTROL-M/Agent administrator to 
modify passwords for users who have forgotten their password. BMC 
recommends that the administrator first use the following command to 
establish a password for user ADMIN:

ctmpwd -action add -user ADMIN -password <user_admin_password>

Table 4-5 ctmpwd Utility – Parameters

Parameter Description

action Function to be executed. 
Valid values: add, update, delete, and list.

user Name of the user.

old_password Current password for the update function.

password Current password for the delete function. 
New password for the add and update functions.

admin_password Password for the CONTROL-M/Agent administrator when 
executing the update or delete function if the 
old_password is not known.

agent Name of the Agent that the utility is designated to run on. 
For more information, see “Invoking A Utility On A 
Computer With Multiple Agents” on page 4-4.
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ctmwincfg Utility

This interactive utility enables you to view and modify the parameters 
listed in Table A-2 on page A-4. If the parameter you want to modify is 
not listed in Table A-2, see the “ctmagcfg Utility” on page 4-8.

Note
BMC recommends to not access the Registry directly but to use ctmagcfg 
or ctmwincfg instead.

Syntax

Run the utility from the command line as follows:

Agent Configuration Utility
Agent Name: Default

        CM Name : WIN
        CM Type : WIN2K

1)      Logon As User (Y/N) . . . . . . . . . . . .: [N]
2)      Logon Domain. . . . . . . . . . . . . . . .: []
3)      Domain Controller . . . . . . . . . . . . .: []
4)      Default Printer . . . . . . . . . . . . . .: []
5)      E-mail User Account . . . . . . . . . . . .: []
6)      E-mail User Account Password. . . . . . . .: [********]
7)      Add Job Object statistics to Sysout (Y/N) .: [Y]
8)      Sysout Name. . . . . . . (MEMNAME|JOBNAME).: [MEMNAME]
9)      Job children inside job object . . .(Y/N) .: [Y]
10)     Wrap parameters with double quotes .(1-4) .: [2]
11)     Run user 'Logon Script' (Y/N) . . . . . . .: []
12)     CD to user 'Home Dir' (Y/N) . . . . . . . .: []

s)      Save and Restart CONTROL-M/Agent Services
q)      Quit

Enter your choice:

Specify values for the parameters you want to change, specify s after the 
prompt “Please enter your choice”, and press <Enter>. If you quit 
without saving, settings are not saved. If you save but do not quit, 
settings are saved anyway.
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5

Defining Microsoft Windows Jobs 5

You can define CONTROL-M jobs with the CONTROL-M/Desktop Job 
Editing form or with the CONTROL-M/Server ctmdefine and ctmcreate 
utilities.

The Job Editing form contains a series of panels. Each panel contains 
parameters whose value you can specify using this form. A job skeleton 
(template) determines the parameters that are included in the job. 

When a job skeleton is designed for Microsoft Windows jobs, a special 
WIN panel is present in the Job Editing form. You can use this panel to 
define optional job object parameters that can be used for a Microsoft 
Windows job.

The following tasks are described in this chapter:

• “Creating a Job Skeleton for Microsoft Windows Jobs” on page 5-2.
• “Creating a Microsoft Windows Job” on page 5-6.
• “Setting Job Object Limits for a Microsoft Windows Job” on page 

5-8
• “Viewing a Job Object” on page 5-11

Microsoft Windows Job Object Parameters are described on page 5-9.

Note
For more information about the Job Editing form and Job parameters, 
see the CONTROL-M/Desktop User Guide and the CONTROL-M Job 
Parameter and Variable Reference Guide.
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Creating a Job Skeleton for Microsoft Windows Jobs

Summary: Use this procedure to prepare a skeleton (template) for Microsoft 
Windows jobs in CONTROL-M/Desktop.

Before You Begin

• Ensure that the windows.xml file was imported on computers where 
CONTROL-M/EM client components are installed. For instructions, 
see Importing WIN Panel Functionality in Chapter 13 of the 
CONTROL-M Installation Guide.

• Look for a skeleton that resembles the skeleton you want to define. If 
you find one, you can use it as a template.

Creating or Modifying a Skeleton

Step 1 Open the Skeleton Editor using one of these methods:

• Choose Tools => Skeleton.
• Click Edit Skeleton  on the toolbar.
• Click Edit Skeletons in the Mass Create Form dialog box.

A window similar to the following is displayed:
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Step 2 Choose the required CONTROL-M from the drop-down list.

Step 3 Click Application. An extra section of the Skeleton Editor is displayed.

Step 4 In the Application Group field, specify the Control Module you want to 
work with (for example, WIN_GROUP).

Step 5 Either:

• Manually specify the appropriate Type, Version, and CM Version
or

• Click Load and choose the appropriate entry from a drop down list.

The appropriate Type is WIN.

Note
If CONTROL-M/Desktop is not connected to CONTROL-M/EM, enter 
the Application Type, Version, and CM Version information manually.

Step 6 In the Form Name field, select WINDOWS.

Step 7 Click OK. 

Where to Go from Here

Subject Location

Defining a Skeleton For more information about defining a skeleton, see 
Chapter 5 of the CONTROL-M/Desktop User Guide.

Defining a Job For information about defining a job, see “Creating a 
Microsoft Windows Job” on page 5-6. Also see 
Chapter 3 of the CONTROL-M/Desktop User Guide.
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Defining the CM in CONTROL-M

Summary: Use this procedure to define the CM in CONTROL-M and install the Job 
Editing form using ctmgetcm.

Before you Begin

• Ensure that the windows.xml file was imported on computers where 
CONTROL-M/EM client components are installed. For instructions, 
see Importing WIN Panel Functionality in Chapter 13 of the 
CONTROL-M Installation Guide.

• Create a job skeleton. For more information, see “Creating a Job 
Skeleton for Microsoft Windows Jobs” on page 5-2.

Creating a CM Definition in CONTROL-M

In CONTROL-M/Server

Step 1 Define a group name with application type WIN.

Step 2 Specify the CONTROL-M/Agent as a node ID in the node group.

Step 3 Specify ctmgetcm to collect application server information from 
CONTROL-M/Agent.

Step 4 Define the <agent_name> in a node group of type WIN (WIN must be in 
capital letters).

Step 5 Run the following command:

ctmgetcm -nodeid <agent_name> -appltype WIN -action get
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In CONTROL-M/EM

Step 1 Install the CONTROL-M/Agent for Microsoft Windows form. For more 
information, see “Creating a Job Skeleton for Microsoft Windows Jobs” 
on page 5-2.

Step 2 Modify the skeleton according to your requirements. Click Application 
in the Skeleton Editor. See page 5-2.

Step 3 Click Load. The node groups available from CONTROL-M/Server are 
displayed. Select the required node group.

Where to Go from Here

Subject Location

Defining a Skeleton For more information about defining a skeleton, see 
Chapter 5 of the CONTROL-M/Desktop User Guide.

Defining a Job For information about defining a job, see “Creating a 
Microsoft Windows Job” on page 5-6. Also see 
Chapter 3 of the CONTROL-M/Desktop User Guide.
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Creating a Microsoft Windows Job

Summary: Use this procedure to create a new CONTROL-M job processing 
definition for a Microsoft Windows job.

Before you Begin

• Ensure that the windows.xml file was imported on computers where 
CONTROL-M/EM client components are installed. For instructions, 
see Importing WIN Panel Functionality in Chapter 13 of the 
CONTROL-M Installation Guide.

• Ensure that a job skeleton was defined for Microsoft Windows jobs. 
For more information, see “Creating a Job Skeleton for Microsoft 
Windows Jobs” on page 5-2.

• The job name of the Windows job you want to create must contain 
only characters (letters, digits, underscore) that can be used in a 
Microsoft Windows file name.

Note
When CONTROL-M/Agent handles a large number of jobs on a 
computer with Microsoft Windows 2000 Professional, the following 
message may be displayed "Application error 142".

Creating a Microsoft Windows Job

Step 1 Select a skeleton for Microsoft Windows jobs from the Current 
Skeleton drop-down list in CONTROL-M/Desktop.

Step 2 Choose one of the following:

• Edit => Job => New Job from the menu bar

• Press Ctrl + J
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• Click 

Note
For descriptions of all panels in the Job Editing form, see Chapter 3 of 
the CONTROL-M/Desktop User Guide.

Step 3 Click the WIN tab of the Job Editing form.

The WIN panel is used to set parameter values for some Microsoft 
Windows jobs. This process is described in “Setting Job Object Limits 
for a Microsoft Windows Job” on page 5-8.

Note
For more information about the Job Editing form and Job Editing 
parameters, see the CONTROL-M/Enterprise Manager User Guide or the 
CONTROL-M/Desktop User Guide.
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Setting Job Object Limits for a Microsoft Windows Job

Summary: Use this procedure to specify values for job object limitation parameters 
in the WIN panel of the Job Editing Form. If a value is not specified for a 
parameter, that parameter does not limit the job in any way.

Before you Begin

The WIN2K skeleton is used for defining job object limitations. If this 
skeleton does not exist, see “Creating a Job Skeleton for Microsoft 
Windows Jobs” on page 5-2.

To view the characteristics of the job object whose attributes are to be 
specified, see “Viewing a Job Object” on page 5-11.

Note
In messages, “job object” may be abbreviated as JO.

Setting Job Object Limits for a Microsoft Windows Job

Step 1 Click the WIN tab of the Job Editing form. The WIN Panel is displayed.

Figure 5-1   WIN Panel
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WIN panel parameters are described in Table 5-1, “Microsoft Windows 
Job Object Parameters,” on page 5-10. All these parameters are optional.

Step 2 Specify new data or modify existing data in the WIN Panel.

Step 3 When you are satisfied with the data in the WIN panel, click Save to 
Draft to save the parameter specifications.

Where to Go from Here

The following table describes where you might find information about 
tasks that are related to this one.

Microsoft Windows Job Object Parameters

WIN panel parameters are described in Table 5-1. This table also 
contains the names of the corresponding AutoEdit variables that can be 
included on the command line or in a parameter input file when invoking 
the CONTROL-M/Server ctmcreate or ctmdefine utilities. For example, 

-autoedit %%WIN2K-PRIORITY_CLASS = “ABOVE_NORMAL_PRIORITY_CLASS“

Note
Values entered in WIN panel fields are validity checked. Values entered 
on the command line or in a parameter input file are not validity checked.

Except for Priority class and Scheduling class, all of these parameters 
can have decimal values (real numbers). Unless stated otherwise, 
maximum and minimum values are machine dependent.

Subject Location

Defining additional 
Microsoft Windows jobs

You can now define additional Microsoft Windows 
jobs by clicking the WIN tab of the Job Editing form.

Viewing jobs you have 
created or modified

Click Cancel to exit the WIN Panel and go to the 
Active environment to view the jobs you have 
created or modified.

Defining jobs For information about defining jobs, see Chapter 3 
of the CONTROL-M/Desktop User Guide.
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Table 5-1 Microsoft Windows Job Object Parameters

Note
You can determine the amount of memory and CPU time required for a 
job by viewing job object statistics in the job sysout. If a job exceeds job 
object limitations, the job will end NOTOK and the same error message 
will appear in the sysout and in the CONTROL-M/Server message log. 
WIN panel parameters are used in CONTROL-M/Agent by the 
SetInformationJobObject API. For more information, see Microsoft 
documentation for the SetInformationJobObject API.

WIN Panel Parameter Definition and AutoEdit Variable for CONTROL-M/Server

Process execution time Maximum CPU time, in seconds, for each process in a job. 
Minimum: 0.1. Maximum: 1.8 x 1012.
%%WIN2K-PER_PROCESS_USER_TIME_LIMIT

Job execution time Maximum CPU time, in seconds, for entire job. Min: 0.1. Max: 1.8 x 1012

%%WIN2K-PER_JOB_USER_TIME_LIMIT

Process memory Maximum memory, in megabytes, allowed for each process in a job. 
Minimum: 0.1. Maximum: 4200.0.
%%WIN2K-PROCESS_MEMORY_LIMIT

Job memory Maximum memory, in megabytes, allowed for job. Min: 0.1. Max: 4200.0
%%WIN2K-JOB_MEMORY_LIMIT

Priority class Highest priority class the job and its “children” can receive. Valid values:
• IDLE_PRIORITY_CLASS
• BELOW_NORMAL_PRIORITY_CLASS
• NORMAL_PRIORITY_CLASS
• ABOVE_NORMAL_PRIORITY_CLASS
• HIGH_PRIORITY_CLASS
• REALTIME_PRIORITY_CLASS
%%WIN2K-PRIORITY_CLASS

Scheduling class Scheduling class for all processes of a job. Valid values: 0 – 9, where 
0 provides the minimum resources, 9 provides the maximum resources.
%%WIN2K-SCHEDULING_CLASS

Minimum Working 
set size

Minimum RAM, in megabytes, for all processes of the job. Increasing the 
value of this parameter reduces page swapping for this process but 
reduces the RAM available for other processes. Min.: 0.1. Max.: 4200.0
%%WIN2K-MINIMUM_WORKING_SET_SIZE

Maximum Working 
set size

Maximum RAM, in megabytes, for all job processes. Decreasing this 
value reduces the likelihood that this job will interfere with other jobs but 
may increase the execution time for this job. Min.: 0.1. Max.: 4200.0
%%WIN2K-MAXIMUM_WORKING_SET_SIZE
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Viewing a Job Object

Summary: This Microsoft Windows procedure enables you to determine job object 
characteristics of any CONTROL-M job. You can use these 
characteristics to decide what job object limits should be specified.

Before you Begin

You can only view Job Object details for a job that is currently running. 
Use the Order or Force option to run the job you want to evaluate.

How to View a Job Object

Step 1 Choose ... => Administrative Tools => Performance. 

Step 2 The Performance window (including its graph panel) is displayed. Click 
the large + button.

Step 3 The Add counters dialog box is displayed.

3.A In the Performance object drop-down list, select JobObject.

3.B Choose All instances to display all existing job object instances.
or
Choose Select instances from list and select one or more of the 
displayed instances.

The job instance format is <job_name>  <order_number>  
<run_number>. These elements are separated by a blank.

3.C Choose Select counters from list. Then, select the characteristic 
in the displayed list that you want to analyze.

To view objects on other Microsoft Windows computers, select 
counters from <name_of_computer> in the Add counters 
dialog box.

3.D Click Add.
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Step 4 Data for the selected “counter” is displayed in the Performance graph. 
Analyze this data to determine whether to specify a related job object 
limit and, if so, the limiting value to specify.

Where to Go from Here

The following table describes where to find information about tasks that 
are related to this one.

Subject Location

Viewing a Job Object If you need to view other characteristics for the 
same job object or view the characteristics of other 
job objects, repeat Steps 3 and 4 of this procedure.

Setting Job Object limits Use the procedure on page 5-8 to specify values for 
the parameters in the WIN tab of the Job Editing 
form.

Defining additional 
Microsoft Windows jobs

You can create additional Microsoft Windows jobs 
by clicking the WIN tab of the Job Editing form. For 
information about defining jobs, see Chapter 3 of 
the CONTROL-M/Desktop User Guide.

Viewing jobs you have 
created or modified

Click Cancel in the WIN tab the Job Editing form to 
go to the Active environment to view the jobs you 
have created or modified.
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A

Configuration Parameters A

Configuration parameters can be modified using the utilities described in 
this chapter, or using the CONTROL-M/Agent GUI. For more 
information about starting the GUI, see “Using the CONTROL-M/Agent 
GUI” on page 2-9.

CONTROL-M/Agent Configuration

The CONTROL-M/Agent configuration parameters in Table A-1 can be 
modified by using the ctmagcfg utility. For information about this utility, 
see “ctmagcfg Utility” on page 4-8.

Table A-1 CONTROL-M/Agent Configuration Parameters (Part 1 of 3)

Parameter Description

Agent-to-Server
Port Number

CONTROL-M/Server and CONTROL-M/Agent communicate by means of two 
TCP/IP ports. This parameter specifies the port in the Server computer that 
receives data from the Agent computer.
• The value specified must match the value assigned to the Agent-to-Server Port 

Number parameter on the Server computer.
• Verify that the specified port number is not used for any other purpose.
• Specify a numeric value from 1025 to 65535, inclusive. Default: 7005

Authorized 
CONTROL-M/
Server Hosts

Names of all CONTROL-M/Server hosts authorized to send requests to this 
Agent. The primary CONTROL-M/Server host must be included.
• Use the “|” symbol to separate host names. 
• Do not include spaces between host names.
• Default: Name of the primary CONTROL-M/Server host.
Note: Specify names, not IP addresses.
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AutoEdit Inline Flag that indicates whether AutoEdit variables defined in a CONTROL-M job are 
set as Environment variables in the user job environment. Valid values are:
Y = AutoEdit variables are set. 
N = AutoEdit variables are not set. Default. 
This parameter can only be changed after completing the installation.

Comm Trace Flag that indicates whether CONTROL-M/Agent – CONTROL-M/Server 
communication packets are written to a file. Valid values: 1 (on), 0 (off).
Default: 0. If set to 1, log files are created for analysis by support staff.

Common Event 
Mechanism

Flag for specifying if all control modules, not just the default control module, 
should be able send messages to the Tracker process without waiting for the 
tracker polling interval. Messages are sent using the port specified in the Tracker 
Port parameter to inform the Tracker that a job ended. Valid values are:
Y = Use the Common Event Mechanism. Default.
N = Do not use the Common Event mechanism. Only the default control module 
can send messages directly to the Tracker process. 
Note: When CONTROL-M/Agent is upgraded from an earlier version, the default 
is N for backward compatibility. 

CTMS Address 
Mode

This flag enables you to handle situations in which the Agent can contact the 
Server by IP address but not by name. Valid values: null and IP. If set to IP, a 
“track all” request from an authorized Server causes the value of the Primary 
CONTROL-M/Server host configuration parameter to be set to the IP address of 
the Server that sent the request.

Daily Log File 
Enabled

Valid values: Y, N. Default: Y
If set to Y, a daily Log file with the name daily_PROCLOG_<YYYYMMDD>.log 
is created in directory <CONTROL-M/Agent home>\DATA. Job begin, job end, 
New Day procedure, and sysout copy messages are written to this log file.

Days to Retain 
Log Files

Number of days to retain programmer debug, communication trace, and Daily log 
files in the proclog directory. Default: 1

Diagnostic 
Level

Flag that indicates whether to generate diagnostic messages. Valid values: 0–4 
Level 0 generates no diagnostics. Level 4 generates maximum diagnostics. This 
parameter is for systems support use and can only be changed after completing 
the installation.

Primary 
CONTROL-M/
Server Host

Host computer for the CONTROL-M/Server that receives and executes requests 
from this Agent. Default: Computer on which the installation was made.

Protocol version Server-Agent communication protocol version. Default: 06

Table A-1 CONTROL-M/Agent Configuration Parameters (Part 2 of 3)

Parameter Description
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Listen to Net 
Card

The network name or IP address for CONTROL-M/Agent for Microsoft Windows 
2000 support of multiple IP interfaces (network cards) for a single computer. Valid 
values are: 
• The network name or IP address of a specific card.
• The reserved value *ANY for all network cards.
This helps ensure that CONTROL-M/Agent will receive requests regardless of 
which IP interface is used to send those requests.

Server-to-Agent
Port Number

CONTROL-M/Server and CONTROL-M/Agent communicate by means of two 
TCP/IP ports. This parameter specifies the port in the Server computer that 
sends data to the Agent computer.
• The value specified must match the value assigned to the Server-to-Agent Port 

Number parameter on the Server computer.
• Verify that the specified port number is not used for any other purpose.
• Specify a numeric value from 1025 to 65535, inclusive. Default: 7006

SSL SSL support for CONTROL-M/Agent for Microsoft Windows. When SSL support 
is implemented in CONTROL-M/Server it makes a one-time request to set this 
parameter automatically for each associated Agent. This request requires 2 to 5 
minutes for each Agent. Setting this parameter manually can save time if a large 
number of Agents work with CONTROL-M/Server. For more information about 
setting this parameter manually, see “ctmagcfg Utility” on page 4-8.

TCP/IP Timeout Communication timeout in seconds. Specify a numeric value greater than or 
equal to zero. Default: 60

Timeout for 
Agent utilities

Maximum time (in seconds) the Agent waits after sending a request to 
CONTROL-M/Server. Default: 600

Tracker 
Polling Interval

Time in seconds that the Tracker waits for a message from a running job before it 
examines the status of all jobs for which no message was received. This 
parameter can only be changed after completing the installation. Default: 60

Tracker 
Port

Number of the port for sending messages to the Tracker process when jobs end. 
This parameter is used in conjunction with the Common Event Mechanism 
parameter. 

Tracker Report 
to Server

Report the status of the job to CONTROL-M/Server. Use this parameter when 
CONTROL-M/Server is working behind a firewall. Valid values are:
• Y – Report the job status. If the Agent is not able to send this report, the job 

remains in executing status.
• N – Do not report the job status. The job status changes to FINISHED when 

the job has completed execution.

Table A-1 CONTROL-M/Agent Configuration Parameters (Part 3 of 3)

Parameter Description
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CONTROL-M Control Module Configuration

The Control Module configuration parameters in Table A-2 can be 
modified by using the ctmwincfg utility. For information about this 
utility, see “ctmwincfg Utility” on page 4-19.

Table A-2 Control Module Configuration Parameters

Parameter Description

Add Job Object 
Statistics to 
Sysout

Flag that indicates how to handle job object processing statistics.
• Selected – Statistics are added to the end of the sysout file. Default.
• Not selected – Statistics are not added to the sysout file.

CD to user 
'Home Dir'

Indication if CONTROL-M/Agent should change the directory to the user home 
directory as defined in the user profile before the user job runs. Valid values:
• Y – The directory is changed.
• N – The directory is not changed.

Default Printer Default printer for job sysout files. Type a printer name in the field box or select a 
name from the list box. Default: Blank

Domain 
Controller

Name of server managing access to resources and the database. Specify the 
name of the server in the field box. Default: Blank

E-mail User 
Password

Password for the e-mail user account. This parameter can only be changed after 
completing the installation.

E-mail User 
Account Profile
(MAPI profile)

User e-mail account which the Agent uses to send e-mail. See the appropriate 
CONTROL-M/Server Administrator Guide for information about the Shout utility. 
This parameter can only be changed after completing the installation.

Job children 
inside job object

Flag that specifies if procedures invoked by a job can be run outside the Job 
Object. If so, this prevents a situation in which the original job remains in 
executing mode until the invoked procedure completes.
• N – All procedures invoked by the job are run outside the job object. 
• Y – All procedures invoked by the job are run inside the job object. Default.

Logon As User Flag that specifies which user account is used for the services to log on to.
• Selected – Jobs are submitted with the permissions and environment 

variables of the specified user.
• Not selected – Jobs are submitted with the permissions and environment 

variables of the local system account. Default.
See “Determining the Owner of Jobs Run on the Agent” on page 2-6.

Logon Domain The domain is determined by the value of this parameter if <domain> is not 
specified in <domain>\<username> in the owner parameter of the job definition. 
If the domain is not specified in the owner parameter or this parameter, the user 
profile is searched in the trusted domains.
Note: BMC recommends that you do not specify a value for Logon Domain.
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Run user 
’Logon Script’

Indication if a user-defined logon script should be run by the CONTROL-M/Agent 
before running the standard user logon script. Valid values:
• Y – The user-defined logon script is run, if it exists.
• N – The user-defined logon script is not run.

Sysout Name Flag that determines the prefix for the Sysout file name. Valid values:
• MEMNAME – The Sysout file prefix is the MEMNAME of the job.
• JOBNAME – The Sysout file prefix is the JOBNAME of the job.
This parameter can only be changed after completing the installation.

Wrap 
parameters with 
double quotes

Indication of how parameter values (%%PARMn....%%PARMx) are handled in by 
CONTROL-M/Agent for Microsoft Windows.Valid values are:
1 – If a parameter value contains a blank, it is passed to the operating system 
enclosed in double quotes. If no blank is in the parameter value, no quotes are 
included.
2 – Parameter values are always passed to the operating system without quotes. 
If quotes were specified in the job definition, they are removed before the 
parameter is passed onward by the agent. This option is compatible with the way 
that these parameters were handled in version 6.0.0x, or 6.1.01 with Fix Pack 1, 
2, 3, or 4 installed. In this case, if a parameter value contains a blank, the 
operating system may consider each string as a separate parameter.
3 – All parameters are passed to the operating system enclosed in 
double-quotes. This causes the operating system to treat all parameter values as 
strings (not numbers). This option is compatible with the way that parameters 
were handled by version 6.1.01 with no Fix Pack installed.
4 – Parameters are passed to the operating system in exactly the same way that 
they were specified in the job definition. No quotes are added or removed in this 
case. This option is compatible with the way that parameters were handled by 
version 2.24.0x.

Table A-2 Control Module Configuration Parameters

Parameter Description
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CONTROL-M Agent Services Configuration

These parameters affect the operation of the following 
CONTROL-M/Agent services:

• Agent service
• Tracker service
• FileWatcher service

Table A-3 System Configuration for CONTROL-M/Agent Services

Parameter Description

Log on as User account under which CONTROL-M Agent and CONTROL-M Tracker 
services will run.
Valid values: Local System Account, This Account.
• Local System Account – Service will log on as the system account. 

Default. Subparameter: 
Allow Service to Interact with Desktop – This option can be selected 
only if the service is running as a local system account. See 
“Maintaining CONTROL-M/Agent Services” on page 2-2.

Selected – the service provides a user interface on a desktop that 
can be used by whoever is logged in when the service is started. 
Default.
Unselected – The service does not provide a user interface.

• This Account – User account under which CONTROL-M Agent and 
CONTROL-M Tracker services will run. See “Logon As User” on page A-4.

Note: If the owner of any CONTROL-M jobs has a “roaming profile” or if job 
output (sysout) will be copied to or from other computers, the Logon mode 
must be set to This Account.

Startup Type How to install CONTROL-M/Agent and CONTROL-M Tracker services. Valid 
values: Automatic, Manual, Disabled. Recommended value: Automatic.
• Automatic – Services should start when the system starts. Default.
• Manual – User or a dependent service can start services.
• Disabled – User or a dependent service cannot start services.
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END USER LICENSE AGREEMENT
NOTICE

BY OPENING THE PACKAGE, INSTALLING, PRESSING “AGREE” OR “YES” OR USING THE PRODUCT, THE ENTITY OR
INDIVIDUAL ENTERING INTO THIS AGREEMENT AGREES TO BE BOUND BY THE FOLLOWING TERMS. IF YOU DO NOT
AGREE WITH ANY OF THESE TERMS, DO NOT INSTALL OR USE THE PRODUCT, PROMPTLY RETURN THE PRODUCT TO
BMC OR YOUR BMC RESELLER, AND IF YOU ACQUIRED THE LICENSE WITHIN 30 DAYS OF THE DATE OF YOUR ORDER
CONTACT BMC OR YOUR BMC RESELLER FOR A REFUND OF LICENSE FEES PAID. IF YOU REJECT THIS AGREEMENT, YOU
WILL NOT ACQUIRE ANY LICENSE TO USE THE PRODUCT.   

This Agreement (“Agreement”) is between the entity or individual entering into this Agreement (“You”) and BMC Software Distribution,
Inc., a Delaware corporation located at 2101 CityWest Blvd., Houston, Texas, 77042, USA or its affiliated local licensing entity (“BMC”).
“You” includes you and your Affiliates. “Affiliate” is defined as an entity which controls, is controlled by or shares common control with a
party. IF MORE THAN ONE LICENSE AGREEMENT COULD APPLY TO THE PRODUCT, THE FOLLOWING ORDER OF LICENSE
AGREEMENT PRECEDENCE APPLIES: (1) WEB BASED LICENSE AGREEMENT WITH BMC, (2) WRITTEN LICENSE
AGREEMENT WITH BMC, (3) SHRINK-WRAP LICENSE AGREEMENT WITH BMC PROVIDED WITH THE PRODUCT, AND (4)THIS
ELECTRONIC LICENSE AGREEMENT WITH BMC. In addition to the restrictions imposed under this Agreement, any other usage
restrictions contained in the Product installation instructions or release notes shall apply to Your use of the Product. 

PRODUCT AND CAPACITY. “Software” means the object code version of the computer programs provided, via delivery or electronic
transmission, to You. Software includes computer files, enhancements, maintenance modifications, upgrades, updates, bug fixes, and
error corrections. 

“Documentation” means all written or graphical material provided by BMC in any medium, including any technical specifications,
relating to the functionality or operation of the Software. 

“Product” means the Software and Documentation. 

“License Capacity” means the licensed capacity for the Software with the pricing and other license defining terms, including capacity
restrictions, such as tier limit, total allowed users, gigabyte limit, quantity of Software, and/or other capacity limitations regarding the
Software. For licenses based on the power of a computer, You agree to use BMC's current computer classification scheme, which is
available at http://www.bmc.com or can be provided to You upon request. 

ACCEPTANCE. The Product is deemed accepted by You, on the date that You received the Product from BMC.

LICENSE. Subject to the terms of this Agreement, as well as Your payment of applicable fees, BMC grants You a non-exclusive,
non-transferable, perpetual (unless a term license is provided on an order) license for each copy of the Software, up to the License
Capacity, to do the following:

(a) install the Software on Your owned or leased hardware located at a facility owned or controlled by You in the country where You
acquired the license; 

(b) operate the Software solely for processing Your own data in Your business operations; and

(c) make one copy of the Software for backup and archival purposes only (collectively a “License”). 

If the Software is designed by BMC to permit you to modify such Software, then you agree to only use such modifications or new
software programs for Your internal purposes or otherwise consistent with the License. BMC grants You a license to use the
Documentation solely for Your internal use in Your operations.

LICENSE UPGRADES. You may expand the scope of the License Capacity only pursuant to a separate agreement with BMC for such
expanded usage and Your payment of applicable fees. There is no additional warranty period or free support period for license
upgrades. 

RESTRICTIONS: You agree to NOT: 

(a) disassemble, reverse engineer, decompile or otherwise attempt to derive any Software from executable code; 

(b) distribute or provide the Software to any third party (including without limitation, use in a service bureau, outsourcing environment,
or processing the data of third parties, or for rental, lease, or sublicense); or

(c) provide a third party with the results of any functional evaluation or benchmarking or performance tests, without BMC's prior written
approval, unless prohibited by local law.



TRIAL LICENSE. If, as part of the ordering process, the Product is provided on a trial basis, then these terms apply: (i) this license
consists solely of a non-exclusive, non-transferable evaluation license to operate the Software for the period of time specified from BMC
or, if not specified, a 30 day time period (“Trial Period”) only for evaluating whether You desire to acquire a capacity-based license to
the Product for a fee; and (ii) Your use of the Product is on an AS IS basis without any warranty, and BMC, ITS AFFILIATES AND
RESELLERS, AND LICENSORS DISCLAIM ANY AND ALL WARRANTIES (INCLUDING, WITHOUT LIMITATION, THE IMPLIED
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT) AND HAVE NO
LIABILITY WHATSOEVER RESULTING FROM THE USE OF THIS PRODUCT UNDER THIS TRIAL LICENSE (“Trial License”).
BMC may terminate for its convenience a Trial License upon notice to You. When the Trial Period ends, Your right to use this Product
automatically expires.   If You want to continue Your use of the Product beyond the Trial Period, contact BMC to acquire a
capacity-based license to the Product for a fee. 

TERMINATION. This Agreement shall immediately terminate if You breach any of its terms. Upon termination, for any reason, You must
uninstall the Software, and either certify the destruction of the Product or return it to BMC. 

OWNERSHIP OF THE PRODUCT. BMC or its Affiliates or licensors retain all right, title and interest to and in the BMC Product and all
intellectual property, informational, industrial property and proprietary rights therein. BMC neither grants nor otherwise transfers any
rights of ownership in the BMC Product to You. Products are protected by applicable copyright, trade secret, and industrial and
intellectual property laws. BMC reserves any rights not expressly granted to You herein.

CONFIDENTIAL AND PROPRIETARY INFORMATION. The Products are and contain valuable confidential information of BMC
(“Confidential Information”). Confidential Information means non-public technical and non-technical information relating to the
Products and Support, including, without limitation, trade secret and proprietary information, and the structure and organization of the
Software. You may not disclose the Confidential Information to third parties. You agree to use all reasonable efforts to prevent the
unauthorized use, copying, publication or dissemination of the Product.

WARRANTY. Except for a Trial License, BMC warrants that the Software will perform in substantial accordance with the Documentation
for a period of one year from the date of the order. This warranty shall not apply to any problems caused by software or hardware not
supplied by BMC or to any misuse of the Software.

EXCLUSIVE REMEDY. BMC’s entire liability, and Your exclusive remedy, for any defect in the Software during the warranty period or
breach of the warranty above shall be limited to the following: BMC shall use reasonable efforts to remedy defects covered by the
warranty or replace the defective Software within a reasonable period of time, or if BMC cannot remedy or replace such defective copy
of the Software, then BMC shall refund the amount paid by You for the License for that Software. BMC's obligations in this section are
conditioned upon Your providing BMC prompt access to the affected Software and full cooperation in resolving the claim. 

DISCLAIMER. EXCEPT FOR THE EXPRESS WARRANTIES ABOVE, THE PRODUCT IS PROVIDED “AS IS.” BMC, ITS
AFFILIATES AND LICENSORS SPECIFICALLY DISCLAIM ALL OTHER WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE
IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT. BMC
DOES NOT WARRANT THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR FREE, OR THAT
ALL DEFECTS CAN BE CORRECTED.

DISCLAIMER OF DAMAGES. IN NO EVENT IS BMC, ITS AFFILIATES OR LICENSORS LIABLE FOR ANY SPECIAL, INDIRECT,
INCIDENTAL, PUNITIVE OR CONSEQUENTIAL DAMAGES RELATING TO OR ARISING OUT OF THIS AGREEMENT, SUPPORT,
AND/OR THE PRODUCT (INCLUDING, WITHOUT LIMITATION, LOST PROFITS, LOST COMPUTER USAGE TIME, AND DAMAGE
OR LOSS OF USE OF DATA), EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, AND IRRESPECTIVE OF ANY
NEGLIGENCE OF BMC OR WHETHER SUCH DAMAGES RESULT FROM A CLAIM ARISING UNDER TORT OR CONTRACT
LAW. 

LIMITS ON LIABILITY. BMC’S AGGREGATE LIABILITY FOR DAMAGES IS LIMITED TO THE AMOUNT PAID BY YOU FOR THE
LICENSE TO THE PRODUCT.

SUPPORT. If Your order includes support for the Software, then BMC agrees to provide support (24 hours a day/7 days a week)
(“Support”). You will be automatically re-enrolled in Support on an annual basis unless BMC receives notice of termination from You
as provided below. There is a free support period during the one year warranty period. 

(a) Support Terms. BMC agrees to make commercially reasonable efforts to provide the following Support: (i) For malfunctions of
supported versions of the Software, BMC provides bug fixes, patches or workarounds in order to cause that copy of the Software to
operate in substantial conformity with its then-current operating specifications; and (ii) BMC provides new releases or versions, so long
as such new releases or versions are furnished by BMC to all other enrolled Support customers without additional charge. BMC may
refuse to provide Support for any versions or releases of the Software other than the most recent version or release of such Software
made available by BMC. Either party may terminate Your enrollment in Support upon providing notice to the other at least 30 days prior
to the next applicable Support anniversary date. If You re-enroll in Support, BMC may charge You a reinstatement fee of 1.5 times what
You would have paid if You were enrolled in Support during that time period. 

 (b) Fees. The annual fee for Support is 20% of the Software’s list price less the applicable discount or a flat capacity based annual fee.
BMC may change its prices for the Software and/or Support upon at least 30 days notice prior to Your support anniversary date. 



VERIFICATION. If requested by BMC, You agree to deliver to BMC periodic written reports, whether generated manually or
electronically, detailing Your use of the Software in accordance with this Agreement, including, without limitation, the License Capacity.
BMC may, at its expense, perform an audit, at your facilities, of Your use of the Software to confirm Your compliance with the
Agreement. If an audit reveals that You have underpaid fees, You agree to pay such underpaid fees. If the underpaid fees exceed 5% of
the fees paid, then You agree to also pay BMC’s reasonable costs of conducting the audit. 

EXPORT CONTROLS. You agree not to import, export, re-export, or transfer, directly or indirectly, any part of the Product or any
underlying information or technology except in full compliance with all United States, foreign and other applicable laws and regulations.    

GOVERNING LAW. This Agreement is governed by the substantive laws in force, without regard to conflict of laws principles: (a) in the
State of New York, if you acquired the License in the United States, Puerto Rico, or any country in Central or South America; (b) in the
Province of Ontario, if you acquired the License in Canada (subsections (a) and (b) collectively referred to as the “Americas Region”);
(c) in Singapore, if you acquired the License in Japan, South Korea, Peoples Republic of China, Special Administrative Region of Hong
Kong, Republic of China, Philippines, Indonesia, Malaysia, Singapore, India, Australia, New Zealand, or Thailand (collectively, “Asia
Pacific Region”); or (d) in the Netherlands, if you acquired the License in any other country not described above. The United Nations
Convention on Contracts for the International Sale of Goods is specifically disclaimed in its entirety.

ARBITRATION. ANY DISPUTE BETWEEN YOU AND BMC ARISING OUT OF THIS AGREEMENT OR THE BREACH OR
ALLEGED BREACH, SHALL BE DETERMINED BY BINDING ARBITRATION CONDUCTED IN ENGLISH. IF THE DISPUTE IS
INITIATED IN THE AMERICAS REGION, THE ARBITRATION SHALL BE HELD IN NEW YORK, U.S.A., UNDER THE CURRENT
COMMERCIAL OR INTERNATIONAL, AS APPLICABLE, RULES OF THE AMERICAN ARBITRATION ASSOCIATION. IF THE
DISPUTE IS INITIATED IN A COUNTRY IN THE ASIA PACIFIC REGION, THE ARBITRATION SHALL BE HELD IN SINGAPORE,
SINGAPORE UNDER THE CURRENT UNCITRAL ARBITRATION RULES. IF THE DISPUTE IS INITIATED IN A COUNTRY
OUTSIDE OF THE AMERICAS REGION OR ASIA PACIFIC REGION, THE ARBITRATION SHALL BE HELD IN AMSTERDAM,
NETHERLANDS UNDER THE CURRENT UNCITRAL ARBITRATION RULES. THE COSTS OF THE ARBITRATION SHALL BE
BORNE EQUALLY PENDING THE ARBITRATOR’S AWARD. THE AWARD RENDERED SHALL BE FINAL AND BINDING UPON
THE PARTIES AND SHALL NOT BE SUBJECT TO APPEAL TO ANY COURT, AND MAY BE ENFORCED IN ANY COURT OF
COMPETENT JURISDICTION. NOTHING IN THIS AGREEMENT SHALL BE DEEMED AS PREVENTING EITHER PARTY FROM
SEEKING INJUNCTIVE RELIEF FROM ANY COURT HAVING JURISDICTION OVER THE PARTIES AND THE SUBJECT MATTER
OF THE DISPUTE AS NECESSARY TO PROTECT EITHER PARTY’S CONFIDENTIAL INFORMATION, OWNERSHIP, OR ANY
OTHER PROPRIETARY RIGHTS. ALL ARBITRATION PROCEEDINGS SHALL BE CONDUCTED IN CONFIDENCE, AND THE
PARTY PREVAILING IN ARBITRATION SHALL BE ENTITLED TO RECOVER ITS REASONABLE ATTORNEYS’ FEES AND
NECESSARY COSTS INCURRED RELATED THERETO FROM THE OTHER PARTY. 

U.S. GOVERNMENT RESTRICTED RIGHTS. The Software under this Agreement is “commercial computer software” as that term is
described in 48 C.F.R. 252.227-7014(a)(1). If acquired by or on behalf of a civilian agency, the U.S. Government acquires this
commercial computer software and/or commercial computer software documentation subject to the terms of this Agreement as
specified in 48 C.F.R. 12.212 (Computer Software) and 12.211 (Technical Data) of the Federal Acquisition Regulations (“FAR”) and its
successors. If acquired by or on behalf of any agency within the Department of Defense (“DOD”), the U.S. Government acquires this
commercial computer software and/or commercial computer software documentation subject to the terms of this Agreement as
specified in 48 C.F.R. 227.7202 of the DOD FAR Supplement and its successors.

MISCELLANEOUS TERMS. You agree to pay BMC all amounts owed no later than 30 days from the date of the applicable invoice,
unless otherwise provided on the order for the License to the Products. You will pay, or reimburse BMC, for taxes of any kind, including
sales, use, duty, tariffs, customs, withholding, property, value-added (VAT), and other similar federal, state or local taxes (other than
taxes based on BMC’s net income) imposed in connection with the Product and/or the Support. This Agreement constitutes the entire
agreement between You and BMC and supersedes any prior or contemporaneous negotiations or agreements, whether oral, written or
displayed electronically, concerning the Product and related subject matter. No modification or waiver of any provision hereof will be
effective unless made in a writing signed by both BMC and You. You may not assign or transfer this Agreement or a License to a third
party without BMC’s prior written consent. Should any provision of this Agreement be invalid or unenforceable, the remainder of the
provisions will remain in effect. The parties have agreed that this Agreement and the documents related thereto be drawn up in the
English language. Les parties exigent que la présente convention ainsi que les documents qui s’y rattachent soient rédigés en anglais.
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